
Integrating MYOB with TimePro 
 

 

With TimePro’s MYOB Integration Module, you can import TimePro time records into MYOB for invoice 

processing or payroll integration.  These records are then used to generate: 

o Sales Invoices,  

o Purchases Invoices (these can be imported into your MYOB Accounting Package direct from TimePro 

and suppliers’ paper invoices can simply be matched against your imported Purchase Invoices rather 

than entered manually); or 

o Activity Slips. 

 

The MYOB Integration Module allows data for Activities, Customers and Suppliers Cards to be exported 

out of MYOB and then integrated with TimePro Customer, Supplier and Activity records.  MYOB Activity 

records are only required to be set up if you are using a MYOB "Sales Invoice Type" of "Time Billing". The 

MYOB Activity ultimately determines which MYOB Income Account sales are recorded against. If you do not 

have a requirement to split your sales Income across multiple accounts in your MYOB Accounting Package, 

then more than likely you will only need to set up one MYOB Activity (e.g. Consulting). This scenario of using 

a single MYOB Activity is the recommended approach for most businesses.  

 

Once the initial data has been imported, records are viewed and maintained using maintenance screens in 

TimePro. Any further changes made to MYOB data can be imported again or maintained on a record-by-

record basis in TimePro. Instructions on setting up the module are contained in Page 2. Note: Entered 

records must have matching entries in both TimePro and MYOB. 

 

How it works 

The following pages provide step by step instructions on the main stages of the MYOB Integration Module. 

o Step 1: Importing MYOB data into TimePro – initial set up integration 

o Step 2: Matching MYOB Activities, Customers and Suppliers with corresponding TimePro Customers, 

Suppliers, Staff Project records 

o Step 3: Export TimePro data into a text file 

o Step 4: Integrate TimePro data into MYOB 

A very powerful feature of TimePro is the ability to extract information from TimePro to generate invoices and 

activity slips for export into a text file and then imported into MYOB. This will save many hours in manual 

Invoice creation. 

MYOB Export Sales Invoices 

TimePro supports the following MYOB related Sales Invoice Types: Time Billing, Professional, Service and 

Miscellaneous/Other. 

MYOB Export Purchases Invoices 

Purchases Invoices will correspond to the invoices received from Contract staff. The great feature of this 

facility is that it alleviates the need to enter invoices that received from Suppliers of Contract Staff into MYOB 

as they will already have been imported into MYOB by this process. All you need do is check that the 

amounts that you have been invoiced match the amounts in MYOB, which is a great way to pick up any 

mistakes in the Suppliers invoices to you. 

MYOB Export Activity Slips 

To meet the requirements of a broad client base, the Activity Slips Export will ignore the "Chargeable" and 

"Export to MYOB" Project flags in the Activity Slips Export process. This is because the Activity Slips Export 

is often used for payroll integration and not just invoicing.



Quick Reference Guide – MYOB Integration Module 
 

 
You have to be logged into TimePro to enable the links to the online help 

Step 1: Configure MYOB Settings 

Step 2: Add MYOB Activities, Customers & Suppliers 
The quickest way is to set up these records is to import them into TimePro (using the 
MYOB Import) rather than adding them individually. 

Set configuration options to match your requirements including which version of 
MYOB you’re using and various invoicing options for your Sales and Purchases. 

Step 3: Match MYOB entries with TimePro Records 

After adding these MYOB entries, you will need to link them with the appropriate 
TimePro Customer, Supplier, Project and Staff Project records located in the Admin 
tab. 

Step 4: Time to Export TimePro data to a .csv file 
The MYOB Export facility gives you the ability to take the time records entered into 
TimePro and to export these records for generating Sales Invoices and Purchases 
Invoices in MYOB. The Sales Invoices, Purchases Invoices and/or Activity Slips are 
then exported in a text file which is then imported into MYOB.  

Only Time records that have been marked as "Completed" are included as part of the 
export process. Therefore it is a good idea to use the Check Timesheets screen to check 
that staff have "Completed" their timesheets and then locking all timesheets before running 
an export. 

The final step is to import the TimePro data (either sales or purchase invoice 
information) into MYOB using MYOB's Data Import Facility. Important: perform a 
backup of your MYOB data file before starting the import. 

Step 5: Import TimePro data into MYOB 



 

Step 1: Setting up the MYOB Integration Module 

 

IN MYOB 
Step 1. Choose one of the following menu options in MYOB 

depending on the data you wish to import into 

TimePro. 

o File->Export Data->Activities 

o File->Export Data->Cards->Customer Cards  

o File->Export Data->Cards->Supplier Cards 

Step 2. On the MYOB Export File screen choose the 

following options: 

o Export File Format: Tab-Delimited  

o First Record is: Header Record 

Leave any other options as they are and press Continue. 

 

Step 3. Choose the fields to export by clicking on them. This 

should place the required field into the Export Fields 

list. 

 

Activity Export : Choose Activity ID 
 

Supplier Export : Choose Co./Last 
Name, Card ID and (optionally) Card 
Status 

Customer Export : Choose Co./Last 
Name, First Name, Card ID and 
(optionally) Card Status 

Step 4. Press Export and then Save to complete the export process. Note: remember the location that you saved 

the file on your computer so that you can find it again later. 

 

IN TIMEPRO 
Step 1. On the MYOB Tab in TimePro press on 

the Import option. 

Step 2. Click on Activities, Customers or 

Suppliers and then choose the file that 

you have exported in the previous steps 

from MYOB by pressing the Browse 

button. 

Step 3. TimePro: Click on Import to start the 

Import process. A confirmation screen 

will be shown once the data import is 

complete. 

 

 



 

 
4  

 

Step 2: Matching TimePro records with MYOB entries 

 

MYOB Customer, Supplier and Activities have to be linked with existing Customer, Supplier, Project 

and Staff Project records in TimePro (located in the “Admin” tab). 

 

 

 

 

CUSTOMER & SUPPLIER ADD/UPDATE 

MYOB Name: Link your TimePro Customer with the 

corresponding Customer record in your MYOB 

system.  

MYOB Supplier Name: Link your TimePro Supplier 

with the corresponding Supplier record in your 

MYOB system.  

You should use the same Names in TimePro as you 

do in MYOB. You may choose to abbreviate these 

names in cases where the MYOB names are very 

long or very formal. 

 

PROJECT ADD/UPDATE/COPY 

MYOB Job: This is an optional field. If you wish to 

track this Project as a Job in MYOB then set this 

field to the corresponding MYOB Job that you have 

created for this project in your MYOB Accounting 

Package (choose the Lists menu, then Jobs in 

MYOB). Remember to make sure that this Job exists 

in MYOB before you import any data into MYOB. 

MYOB Comment: Set this field to contain any 

specific information that you wish to include on the 

Sales Invoice that is generated by MYOB eg. 

Customer's Purchase Order Number. 

Export to MYOB: Set this field to Yes if you wish 

Time recorded by your staff against this project to be 

used to generate Sales Invoice details for export to 

MYOB. If No is selected then this Project will be 

skipped when an MYOB export is performed. 

STAFF PROJECT ADD/UPDATE/COPY 

Description: The Description is a very important 

field as it is used as the description for line items on 

MYOB Sales Invoice Exports. Include the tag 

[StaffName] in the Description field to have the Staff 

members First Name and Surname substituted 

automatically into this field when data pertaining to 

this record is exported to MYOB.  

MYOB Activity: Set it to the MYOB Activity that you 

want this Staff Project record to be linked with.  

MYOB Line Item Order: Set this field to a number 

such as 10, 20, 30, as it is used for ordering line 

items on your MYOB Sales Invoices.  
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Step 3: MYOB Export Selection Criteria (Sales Invoice) 

 

 

 

 

 

 

 

o Uninvoiced Time Records up to a 

specified date 

The normal mode of operation is to select all 

time records which have been marked as 

complete but which are as yet uninvoiced. You 

are then able to review the invoices which would 

result from these time records, and you can omit 

entire invoices, invoice line-items, or individual 

time records, postponing these until a later 

invoice batch. An invoice batch number is 

automatically assigned, and you can then print 

all timesheets which match this batch. The 

default value is the last day of the period before 

the current one. 

o Time Records for the Period 

You may also select all items for a specific time 

period, which is by default the period preceding 

the current period. It is important to note that this 

will select all completed time records for the 

period you specify, whether or not they have 

already been invoiced. This allows you to 

produce a new invoice to replace one previously 

produced. You would normally proceed by de-

selecting all records, and then selecting 

specifically the information for which you want to 

produce the invoice or invoices. You should bear 

in mind that this will produce a new invoice 

batch, and time records previously assigned to 

an earlier batch will be removed from that batch 

and assigned to the new one. 

o Invoice Date 

As well as specifying the way time records are to be selected, you also need to specify the date 

which is to appear on invoices. TimePro will suggest the first day of the current period. 

o Invoice Content 

The last item you need to specify is the content of each invoice, meaning the conditions under which 

a new invoice will be produced 

o Activity ID 

The Activity ID can be taken from a number of fields: Projects: MYOB Job, Staff Projects: Cost Code, 

Staff Projects: Description, Staff Projects: MYOB Activity ID, Staff Projects: Activity ID, Staff Projects: 

Role, Staff: Reference, Task: Description, Task: External ID, or a value can be specified by choosing 

Use Value Below.  

o Customer 

You can optionally limit the export to a single Customer if required. 

o Prepare Invoices 

When you click on this button, the time records which satisfy your selections above are gathered and 

grouped into invoices, and displayed in the MYOB Export Item Selection page. 

If you have prepared a Sales Invoice 

Batch for MYOB using this screen 

and subsequently realise that you 

have made a mistake in the data that 

was selected for Export, you can 

reverse out the batch using this 

option. There is also an option to 

"View Batch" so that you can verify 

the records that will be reversed 

before actually performing the 

"Undo" operation. 

Note: Once a batch has been 

"undone" it is still shown in the batch 

list but is prefixed with an "X" to 

indicate that it has been backed out. 
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On the MYOB Export Item Selection screen, you are presented with a list of the 

invoices which can be produced from the time records you have selected. What you 

see will depend on your browser. 

Each row of information also has a selector button and is selected by default. 

o If you selected time records for a date range you would typically start by 

pressing the Select None button (this can take a few seconds to 

complete). You would then select the items you wish to include in the 

invoice run. 

o If you selected uninvoiced time records you would review the invoices and 

may choose to select items to exclude from the invoice run. 

You may select information at any level of detail to include that item and everything 

at a lower level. You may deselect an item to exclude it and all lower-level detail. If 

some items at a level are selected and others not selected, the next-higher parent 

level will be part-selected. The line-item and invoice values are adjusted in 

response to your selections. 

Once you are satisfied that the invoices are as you wish to see them, click on the 

Create Batch button. This will take you to the MYOB Export Save Batch screen.  

This screen shows you the batch number allocated to this information. You should 

note this number so that you can specify it in the batch print to select time sheets to 

match these invoices. At this point you get a last chance to change the batch. If you 

choose the Re-do Selections button, you will be returned to the MYOB Export Item 

Selection screen to repeat the process, and you will replace this batch when you 

complete the selection. 

Normally you would continue with the Export Invoice Data button. This will open up 

a new browser window (Data Export Complete) which includes a link which you can 

use to open the exported data file or to save the exported data in the location from 

which you will import it to MYOB. 
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MYOB Export - Purchase Invoice 

 

First select the Period Beginning from the dropdown list 

which has been pre-populated with dates based on the 

system configuration settings in the application. Once a 

date has been chosen from the dropdown list, the system 

automatically displays the period for which data will be 

extracted. 

 

 

 

 

The Invoice Date is defaulted as the first day following the 

end of the period selected. The Detail Date is defaulted as 

the date that marks the start of the period selected. These 

values can be changed manually if you require different 

dates to appear on your purchase invoices. 

The Invoice Content determines exactly how your 

Purchases Invoices are generated. A default is selected 

based on specific MYOB Configuration Settings. For 

example, if one of your Supplier's contractors is currently 

working on 3 Projects for one of your Customers, then you 

may wish to create only one invoice to cover all the 

Projects or you may want to generate a separate invoice 

for each Project (3 in this case). You can modify the option 

here so that the Invoices are generated in the manner you 

wish. The most common option is to generate One Invoice 

per Supplier and Project which is the default option. 

Press the "Export" button to initiate The MYOB Export 

process. 

A Data Export Complete screen then shows the number of 

records extracted and also provides a link to the exported 

file. You should right-click on the link and save the target 

file to your computer. 
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MYOB Export - Activity Slips 

 

Specify whether you wish to export Time Records, Expenses or Both 

 

 

 

Content of the Notes field 

Choose the detail you want to appear in the Notes included in the Activity 

Slips. By default, the Task details are included (if you use tasks), as are the 

manually-typed descriptions (if you use these). You may choose to prefix 

the Notes with the name of the Staff member doing the work and with the 

Project Description.  

Value to be supplied for the Rate 

Specify whether the rate is to be taken from the Staff Project record or 

MYOB.  

Value to be supplied for the Activity ID 

The Activity ID can be pulled from a number of fields within TimePro:  

Projects: MYOB Activity ID, Staff Projects: Cost Code, Staff Projects: 

Description, Staff Projects: MYOB Activity ID, Staff Projects: Role, Staff: 

Reference, Task: Description, Task: External ID, or you can specify a value.  

Value to be supplied for the MYOB Job 

The MYOB job can be pulled from a number of fields within TimePro, 

Projects: MYOB job, Staff Projects: Cost Code, Staff Projects: Description, 

Staff Projects: MYOB Activity ID, Staff Projects: Role, Staff: Reference, 

Task: Description, Task: External ID, or you can specify a value. 
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Choose whether the Activity Slips are to be marked for integration with 

the Payroll, and if so, the Payroll Category which is to be used.The 

MYOB Payroll Category can be pulled out from a number of fields from 

within TimePro: MYOB job, Staff Projects: Cost Code, Staff Projects: 

Description, Staff Projects: MYOB Activity ID, Staff Projects: Role, Staff: 

Reference, Task: Description, Task: External ID, or you can specify a 

value. 

Click on "Create the Export File" to generate a text file, which will be 

listed on a new screen. 

 

A Data Export Complete screen then shows the number of records 

extracted and also provides a link to the exported file. You should right-

click on the link and save the target file to your computer. 
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Step 4: MYOB Import Instructions - 
Sales Invoices, Purchase Invoices and Activity Slips 

The final step is to import the TimePro data (either sales or purchase invoice information) into MYOB using 

MYOB's Data Import Facility.  Only Time records that have been marked as "Completed" are included as 

part of the export process.  

 

Step 1. Perform a backup of your MYOB data file (IMPORTANT) 

It is recommended as good practice to do a backup of your 

MYOB data file prior to using the MYOB Import facility 

especially until you are familiar with the process. 

 

Step 2. Choose one of the following menu options in MYOB 

depending on the type of data you exported earlier: 

Sales 

o File->Import Data->Sales->Time Billing (default) 

o File->Import Data->Sales->Professional 

o File->Import Data->Sales->Service 

o File->Import Data->Sales->Miscellaneous 

Purchases 

o File->Import Data->Purchases->Professional 

o File->Import Data->Purchases->Service 

o File->Import Data->Purchases->Miscellaneous 

Step 3:  On the MYOB Import File screen choose the following 

options: 

o Export File Format: Tab-Delimited 

o First Record is: Header Record 

o Identify Customers By: Co./Last Name 

Leave any other options as they are and press Continue. 

 

Step 4. Select the file you saved during the TimePro MYOB 

Export process earlier and press Open.  

Note: make sure that you do not have the file already open 

in another program (eg looking at the file in Excel) 

otherwise you will get an error. 

 

Step 5. Press Match All and check that the fields in the MYOB 

Fields and Matching Import Fields columns are the 

same by quickly scrolling through the list.  

Note: if the fields don't match up then you have probably 

chosen the wrong file for the selected MYOB Import option. 

Cancel out and try again. 
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Step 6. Press Import to start the Import process. 

Step 7. Carefully check the Import Completion Screen to see if 

there have been any MYOB Errors.  Refer to 

“MYOBLOG.TXT” for error messages. 

 

Step 8. Review the invoices that have been imported into 

MYOB by opening the MYOB Transaction Journal and 

choosing the Sales or Purchases tab.  

In the Date From and To search fields enter the Invoice 

Date that you specified in the TimePro MYOB Export 

screen. You will now see a list of the Invoices that you have 

imported. Note the word Imported is displayed against all of 

the invoices that have been created via the MYOB Data 

Import facility, making them easy to identify. If you need to 

modify or delete any invoices that you have imported, then 

you can do so safely on this screen, as you would for any 

other invoices that you create in MYOB. 
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Integrating MYOB Activity Slips Import with Payroll  

 

Time records exported as MYOB Activity Slips may be marked for Payroll Integration against a Payroll Category (defaults 

as “BaseHourly”). To import Activity Slips for payroll integration, you will need to set your MYOB system up as follows  
 

In MYOB: 

• Set up your MYOB Preferences to ensure that the option for “I Use Timesheets for Time Billing and Payroll…“ is 
checked: 

 

 

 

• Access the Employee Card and, for each employee, define their settings as follows: 
 

1. Set Standard Pay for Base Hourly Category to “0”: 
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2. Check that Wages details are associated with the Base Hourly Payroll Category: 

 

 

 

In TimePro: 

• When undertaking an Activity Slips export, make sure that the Activity Slips are marked for Payroll Integration 
and that you enter the correct MYOB Payroll Category name for integration with the Activity Slips. 
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• Conduct the export from TimePro and import to MYOB as usual for payroll processing. You will note that the 
Activity Slips now register as hours recorded as Timesheet Hours: 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

This guide has been developed to provide an overview of how to integrate MYOB with TimePro.  

Comprehensive information can be sourced from the TimePro Online Help manual available via the Help 

section of your Intertec TimePro system. 

 

 

 

 
Contact Details: 

Further assistance is available from the Intertec TimePro team  

� (08) 9286 3911 � support@timesheets.com.au  


